[cmake-developers] Alternate if() without implicit variable expansion

Nils Gladitz nilsgladitz at gmail.com
Thu Sep 4 10:51:03 EDT 2014


On 09/04/2014 04:40 PM, Brad King wrote:
> On 09/04/2014 10:25 AM, Nils Gladitz wrote:
> I think a new command would ("if_noexpand") would make the "correct"
> code less readable than the "incorrect" code.  Also the implicit-bool
> conversion of variables is more readable IMO; consider
>
>   if(${FOO_FOUND})
>
> versus
>
>   if(FOO_FOUND)

I am rather used to "if()" as well but safe_if()/if_noexpand() might 
still be more readable than the workarounds that people are using now to 
get something close to the expected behavior with regular if() [1].

You would also still be able to use regular if() in cases where you 
prefer the aesthetics of implicit-bool.

Nils

[1] http://www.cmake.org/pipermail/cmake/2014-September/058476.html



More information about the cmake-developers mailing list