View Issue Details Jump to Notes ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008954CMakeModulespublic2009-05-01 17:152016-06-10 14:30
ReporterTrent Lillehaugen 
Assigned ToMiguel Figueroa 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionmoved 
PlatformOSOS Version
Product VersionCMake-2-6 
Target VersionFixed in Version 
Summary0008954: Finding wxWidgets contrib modules is not supported in Windows
DescriptionI was trying to use the wxWidgets module STC which is part of the "contrib" folder. My CMakeLists.txt file contained the following line:

find_package(wxWidgets REQUIRED stc core base)

However, when running CMake under Windows, I get the following error:

Could NOT find wxWidgets (missing: wxWidgets_FOUND)

It works correctly under Cygwin (I was told on the mailing list this is because the unix variants use wx-config)

The compiled contrib libraries can be found in the same directory as the included modules. In may case the live in:
...\wxWidgets-2.8.10\lib\vc_lib
The Header files are in:
...\wxWIdgets-2.8.10\contrib\include
TagsNo tags attached.
Attached Filespatch file icon contrib.patch [^] (1,109 bytes) 2009-05-05 12:09 [Show Content]
? file icon commit-36648cb [^] (1,304 bytes) 2009-08-25 01:46 [Show Content]
patch file icon wxwidgets_find_contrib_01.patch [^] (1,294 bytes) 2009-08-25 02:15 [Show Content]

 Relationships

  Notes
(0016290)
Trent Lillehaugen (reporter)
2009-05-05 12:11

I've attached a patch that works for me. I have only added support for STC and am still new to CMake, but I hope it will help jump-start the official fix.
(0017203)
gnu_lorien (reporter)
2009-08-25 01:15

There also needs to be a change to line 284 to include fl. It seems like this should actually generalized to hunt through all of the contrib code.
(0017204)
gnu_lorien (reporter)
2009-08-25 01:47

This is a patch that will find all of the contrib libraries I am aware of.
Most importantly, it finds FL which happens to be the blocker for a project I use CMake for.
(0017205)
gnu_lorien (reporter)
2009-08-25 02:15

Fixed up an incorrect include for the contrib libraries.
(0019746)
Miguel Figueroa (developer)
2010-03-07 04:03

I'm looking into your patch now. Could you provide an output of your directory structure (where is the include/lib dirs) with a full listing of the library dir?

Thanks,
--Miguel
(0019761)
gnu_lorien (reporter)
2010-03-08 14:33

Unfortunately I can't. I have changed jobs and no longer have access to the source code repository where I was doing this work and I just don't remember the layout.
(0041551)
Kitware Robot (administrator)
2016-06-10 14:27

Resolving issue as `moved`.

This issue tracker is no longer used. Further discussion of this issue may take place in the current CMake Issues page linked in the banner at the top of this page.

 Issue History
Date Modified Username Field Change
2009-05-01 17:15 Trent Lillehaugen New Issue
2009-05-02 16:18 Miguel Figueroa Status new => assigned
2009-05-02 16:18 Miguel Figueroa Assigned To => Miguel Figueroa
2009-05-05 12:09 Trent Lillehaugen File Added: contrib.patch
2009-05-05 12:11 Trent Lillehaugen Note Added: 0016290
2009-07-18 10:42 Philip Lowman Category CMake => Modules
2009-08-25 01:15 gnu_lorien Note Added: 0017203
2009-08-25 01:46 gnu_lorien File Added: commit-36648cb
2009-08-25 01:47 gnu_lorien Note Added: 0017204
2009-08-25 02:15 gnu_lorien File Added: wxwidgets_find_contrib_01.patch
2009-08-25 02:15 gnu_lorien Note Added: 0017205
2010-03-07 03:55 Miguel Figueroa Relationship added duplicate of 0009775
2010-03-07 04:03 Miguel Figueroa Note Added: 0019746
2010-03-07 13:45 Miguel Figueroa Relationship deleted 0009775
2010-03-08 14:33 gnu_lorien Note Added: 0019761
2016-06-10 14:27 Kitware Robot Note Added: 0041551
2016-06-10 14:27 Kitware Robot Status assigned => resolved
2016-06-10 14:27 Kitware Robot Resolution open => moved
2016-06-10 14:30 Kitware Robot Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team