View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008102CMakeCMakepublic2008-11-14 14:272013-04-17 08:54
ReporterClemens 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product VersionCMake-2-6 
Target VersionCMake 2.8.11Fixed in VersionCMake 2.8.11 
Summary0008102: CMake support for mobile platforms in Visual Studio 2005/2008
DescriptionThe patch included adds two new Visual Studio generators (2005 and 2008) to CMake which include platform support for SDKs for mobile devices. This mainly goes conform with the feature request from Andreas Pokorny (0007919) for WinCE support in NMake and uses his WINCE platform files.

Additional InformationThe patch is against the original 2.6.2 release sources. Unfortunatly I could not create files named after the files modified, but all files in the archive are in unified diff format.

There are a few things I already mentioned in the forum.

# The generators include special link flag tables, which I find to be a useful feature also for upcoming releases of Visual Studio.

# Because introducing a new generator needs a really deep patch into cmake, the changes should be revised carefully (patched cmake.cxx, CMakefile.cxx etc.). However, we are testing the changes currently on multiple machines and they also work well with PPC2003/SmartPhone2003,WinMobile5,WinMobile6 and WinCE5.0.

# In principle the generators parse a file called WCE.VCPlatform.config residing in %STUDIODIR%\VC\vcpackages to get a list of SDKs installed. It also takes a list SDKs to use from a CMakeCache.txt to be copied to the build directory prior to configuration. Such a file might contain the following:

CMAKE_SYSTEM_NAME:STRING=WINCE
CMAKE_SYSTEM_VERSION:STRING=5.01
PLATFORM_SDKS:STRING=Windows Mobile 5.0 Pocket PC SDK (ARMV4I);Windows Mobile 5.0 Smartphone SDK (ARMV4I)
WM5:STRING=1

for Windows Mobile 5 for example. The generators only filter the platforms specified from all possible ones. However, if no cache file is supplied, it creates a configuration for all platforms installed.
TagsNo tags attached.
Attached Fileszip file icon cmake_2.6.2p_files.zip [^] (33,906 bytes) 2008-11-14 14:27
patch file icon cmake-2.6.3.patch [^] (121,540 bytes) 2009-02-24 03:45 [Show Content]
patch file icon cmake-2.6.3_1.patch [^] (145,143 bytes) 2009-03-30 07:00 [Show Content]
diff file icon cmake-2.6.4.diff [^] (146,075 bytes) 2009-05-02 07:02 [Show Content]
diff file icon cmake-2.6.4_new.diff [^] (254,782 bytes) 2009-06-04 08:10 [Show Content]
diff file icon cmake-2.6.4_new_040609.diff [^] (149,456 bytes) 2009-06-04 08:58 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
duplicate of 0007919closedBrad King Patch for Windows Platform files to add WinCE support with NMake 
related to 0008486closedKitware Robot Additional platforms support (Windows CE and Symbian) 

-  Notes
(0015323)
Clemens (reporter)
2009-02-24 03:45

Hi again,

I downloaded the 2.6.3 sources on Windows and patched them to include the Windows Mobile support. I have created a patch with TortoiseSVN, so it should be easy to test my changes applying my patch to virginal 2.6.3 sources.

Regards
Clemens
(0015845)
Clemens (reporter)
2009-03-30 07:01

As discussed in the forum I have tried to generate a test for the framework, which currently works only for Visual Studio 9 2008!
(0016276)
Clemens (reporter)
2009-05-02 07:02

Uploaded patch against 2.6.4, also including the test project
(0031751)
Brad King (manager)
2012-11-28 16:13

Resolving as duplicate of 0007919 which has now been addressed.
(0032887)
Robert Maynard (manager)
2013-04-17 08:54

Closing resolved issues that have not been updated in more than 4 months.

- Issue History
Date Modified Username Field Change
2008-11-14 14:27 Clemens New Issue
2008-11-14 14:27 Clemens File Added: cmake_2.6.2p_files.zip
2008-12-15 10:08 Bill Hoffman Status new => assigned
2008-12-15 10:08 Bill Hoffman Assigned To => Bill Hoffman
2009-02-24 03:45 Clemens Note Added: 0015323
2009-02-24 03:45 Clemens File Added: cmake-2.6.3.patch
2009-03-30 07:00 Clemens File Added: cmake-2.6.3_1.patch
2009-03-30 07:01 Clemens Note Added: 0015845
2009-05-02 07:02 Clemens Note Added: 0016276
2009-05-02 07:02 Clemens File Added: cmake-2.6.4.diff
2009-06-04 08:10 Clemens File Added: cmake-2.6.4_new.diff
2009-06-04 08:58 Clemens File Added: cmake-2.6.4_new_040609.diff
2009-06-05 13:05 David Cole Relationship added related to 0007919
2012-11-28 16:12 Brad King Relationship replaced duplicate of 0007919
2012-11-28 16:13 Brad King Note Added: 0031751
2012-11-28 16:13 Brad King Assigned To Bill Hoffman =>
2012-11-28 16:13 Brad King Status assigned => resolved
2012-11-28 16:13 Brad King Resolution open => duplicate
2012-11-28 16:13 Brad King Fixed in Version => CMake 2.8.11
2012-11-28 16:13 Brad King Target Version => CMake 2.8.11
2012-11-28 16:13 Brad King Relationship added related to 0008486
2013-04-17 08:54 Robert Maynard Note Added: 0032887
2013-04-17 08:54 Robert Maynard Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker