View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0014201CMakeModulespublic2013-06-04 10:492016-06-10 14:31
ReporterMarcel Beister 
Assigned ToKitware Robot 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionmoved 
Platformx64OSWindowsOS Version7
Product VersionCMake 2.8.11 
Target VersionFixed in Version 
Summary0014201: FindCUDA does not forward include directories assigned by target_include_directories()
DescriptionI switched from directory-based to target-based include directories and NVCC does not get the include directories assigned to the target. I assume the problem is, that when cuda_add_library() or cuda_add_executable() is called, this information is not yet available since target_include_directories() can only be called on an already existing target which is after the cuda_add_...() calls.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0033236)
Brad King (manager)
2013-06-04 10:56

Discussion started here:

 http://thread.gmane.org/gmane.comp.programming.tools.cmake.devel/7040/focus=7041 [^]
(0042297)
Kitware Robot (administrator)
2016-06-10 14:29

Resolving issue as `moved`.

This issue tracker is no longer used. Further discussion of this issue may take place in the current CMake Issues page linked in the banner at the top of this page.

- Issue History
Date Modified Username Field Change
2013-06-04 10:49 Marcel Beister New Issue
2013-06-04 10:52 Brad King Status new => backlog
2013-06-04 10:56 Brad King Note Added: 0033236
2016-06-10 14:29 Kitware Robot Note Added: 0042297
2016-06-10 14:29 Kitware Robot Status backlog => resolved
2016-06-10 14:29 Kitware Robot Resolution open => moved
2016-06-10 14:29 Kitware Robot Assigned To => Kitware Robot
2016-06-10 14:31 Kitware Robot Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker