View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011153CMakeCMakepublic2010-08-19 17:182013-10-07 10:03
ReporterClausKlein 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product VersionCMake-2-8 
Target VersionFixed in Version 
Summary0011153: cmake out of source build writes build files at source dirs
Description I discovered than in the special case of a substituted PROJECT_SOURCE_DIR,
all build files for subdir packages are created in PROJECT_SOURCE_DIR and not at the PROJECT_BINARY_DIR.

I use windows XP cmd shell
     subst w: z:/some/deep/path/to/source/dir

Than I create a new build dir:

cd /d w:/
mkdir build
cd build
cmake ..


after that, all subdirs of the source dir are created as
w:/build<subdir1>
w:/build<subdir2>
...
filled with the cmake build files.

I tested cmake 2.8.0, 2.8.1 and 2.8.2 version. all have the same behaviour!
The created project builds fine too.

It seems that the PROJECT_BINARY_DIR and the subdir paths are concatenated without a path separator.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of 0010072closedBrad King invalid binary path if makefile in root directory 
related to 0010994closedBrad King Windows: find_* commands can find paths with no drive letter 

-  Notes
(0021894)
Brad King (manager)
2010-08-23 11:22

This commit may address the problem:

http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=0a21abd6 [^]
(0023793)
David Cole (manager)
2010-12-08 08:23

Does CMake 2.8.3 have the same issue?

Did Brad's referenced commit in the previous note fix this?

Thanks,
David
(0024371)
Bill Hoffman (manager)
2011-01-03 17:35

Is this still an issue?
(0024402)
ClausKlein (reporter)
2011-01-04 16:50

Yes this is still an issue, tested with CMake 2.8.3 on Windows XP
(0024403)
Bill Hoffman (manager)
2011-01-04 17:20

Hmm, sounds like cmake does not like the subst command. I am not even sure how one would add support for something like that...
(0024404)
David Cole (manager)
2011-01-04 17:46

This has nothing to do with "subst" per se, and everything to do with the combination of: a CMakeLists.txt at the root of a Windows drive letter, and add_subdirectory calls in that CMakeLists file.

Easily reproducible with putting a CMake-based source tree at the root of any Windows drive...
(0024405)
David Cole (manager)
2011-01-04 17:52

The easy workaround, of course, is to put your source tree in a directory named "s" and map it such that the full path to the source tree is "w:/s"

That should avoid the problem. (At least, it did for me, when I backed up one level on the subst-ing...)
(0024428)
David Cole (manager)
2011-01-05 12:46

Unsetting the target version field. Since there is an easy workaround, and plenty of other more important bugs to try to finish for the 2.8.4 release, this one is: deferred until later.
(0028358)
Patrick Spendrin (reporter)
2012-01-18 16:10

A duplicate of this bug: http://public.kitware.com/Bug/view.php?id=10072 [^]
(0032537)
Brad King (manager)
2013-03-08 08:05

Resolving as duplicate of 0010072.
(0033983)
Robert Maynard (manager)
2013-10-07 10:03

Closing resolved issues that have not been updated in more than 4 months.

- Issue History
Date Modified Username Field Change
2010-08-19 17:18 ClausKlein New Issue
2010-08-23 11:22 Brad King Note Added: 0021894
2010-12-08 08:23 David Cole Assigned To => David Cole
2010-12-08 08:23 David Cole Status new => assigned
2010-12-08 08:23 David Cole Note Added: 0023793
2010-12-17 07:41 David Cole Target Version => CMake 2.8.4
2011-01-03 17:35 Bill Hoffman Note Added: 0024371
2011-01-04 16:50 ClausKlein Note Added: 0024402
2011-01-04 17:20 Bill Hoffman Note Added: 0024403
2011-01-04 17:46 David Cole Note Added: 0024404
2011-01-04 17:52 David Cole Note Added: 0024405
2011-01-05 12:46 David Cole Note Added: 0024428
2011-01-05 12:46 David Cole Target Version CMake 2.8.4 =>
2011-01-05 19:26 David Cole Relationship added related to 0010994
2011-10-25 22:53 David Cole Assigned To David Cole =>
2011-10-25 22:53 David Cole Status assigned => backlog
2012-01-18 16:10 Patrick Spendrin Note Added: 0028358
2013-03-08 08:03 Brad King Relationship added duplicate of 0010072
2013-03-08 08:05 Brad King Note Added: 0032537
2013-03-08 08:05 Brad King Status backlog => resolved
2013-03-08 08:05 Brad King Resolution open => duplicate
2013-10-07 10:03 Robert Maynard Note Added: 0033983
2013-10-07 10:03 Robert Maynard Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker