[CMake] cmake not found

David Henderson dnadavewa at yahoo.com
Wed May 4 13:32:50 EDT 2011

I was abbreviating for conciseness on the path.  I've tried running this in  
an MSYS cmd window and get the same error.

I've spent the morning trying to dump out as many environment variables that  
may be related as possible.

This is really frustrating as the build just works on Linux...

Sent via DROID on Verizon Wireless

-----Original message-----
From: David Cole <david.cole at kitware.com>
To: David Henderson <dnadavewa at yahoo.com>
Cc: cmake at cmake.org
Sent: Tue, May 3, 2011 10:25:23 GMT+00:00
Subject: Re: [CMake] cmake not found

I guess the "/cygdrive/e/workspace/GSDesignGUI" must be from the MSYS make
program then...

Are you really doing a "cmake ../src/explorergui" from the root of the E:
drive? Or were you just abbreviating in your email?

Has anybody else seen this error with the MSYS Makefiles generator?

The E:> suggests you're running it in a Windows command prompt. Are you
running in an MSYS prompt? If not, try it from an MSYS prompt, and let us
know how that goes.

On Mon, May 2, 2011 at 5:21 PM, David Henderson <dnadavewa at yahoo.com> wrote:

> Hello David:
> I do not have cygwin installed.  Anywhere.  I also did a search for
> cmake.exe and the only one available is the one in the cmake installation.
> I have version 2.8.4 installed.
> Thanks!!
> Dave H
> ------------------------------
> *From:* David Cole <david.cole at kitware.com>
> *To:* David Henderson <dnadavewa at yahoo.com>
> *Cc:* cmake at cmake.org
> *Sent:* Mon, May 2, 2011 7:l28:00 AM
> *Subject:* Re: [CMake] cmake not found
> Looks to me like you're using the cygwin cmake.
> Use the native Windows cmake instead for generating with the "MSYS
> Makefiles" generator.
> They differ in how they treat paths to file names.
> On Fri, Apr 29, 2011 at 9:01 PM, David Henderson  
<dnadavewa at yahoo.com>wrote:
>> I'm having trouble compiling a project using cmake.  Here is the output
>> from the
>> command line execution of the offending line of my Makefile on Windows 7
>> 64bit:
>> E:> cmake -G "MSYS Makefiles" ..

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.cmake.org/pipermail/cmake/attachments/20110504/b0aeb00b/attachment-0001.htm>

More information about the CMake mailing list