[CMake] append command

Alexander Neundorf a.neundorf-work at gmx.net
Thu Aug 11 16:04:10 EDT 2011


On Thursday 11 August 2011, Michael Hertling wrote:
...
> Alternatively, one might consider to introduce a new, say,
> modifier "CONCAT" for the SET() command, e.g.
> 
> SET(<variable> <value> ... CONCAT [SEP <sep>])
> 
> equivalent to
> 
> SET(<variable> "${<variable>}<sep><value>...")

I'm not sure this is actually necessary.
Personally I'm fine with 
set(foo "${foo} bar")
It's just one line. For properties more code is needed otherwise.

> again with <sep> defaulting to a space. This would preserve the
> STRING() command's strict distinction between input and output
> variables. Anyway, I agree that this whole APPEND/CONCAT issue
> isn't a serious problem but just a convenience feature.
> 
> Besides, David, due to the same reasons as mentioned above, the new
> APPEND_STRING subcommand of SET_PROPERTY() is quite misnamed, IMO -
> and quite long. Would it be possible to rename it to CONCAT before
> it is released officially? In this way, we would consistently have
> APPEND subcommands for list-style variables/properties and CONCAT
> subcommands for string-style ones.

We can do that, if other people think also that this would be a better name.
Or "STRING_APPEND" instead of "APPEND_STRING" ?

Alex


More information about the CMake mailing list