[CMake] Error at FindKDE3.cmake: "mode MATCH needs at least 5 arguments"

Alexander Thomas alexander.thomas at esat.kuleuven.be
Tue Feb 3 08:05:10 EST 2009

Bill Hoffman wrote:
> Alexander Thomas wrote:
>> I have a project which uses Qt3, with a CMakeLists.txt containing 
>> these lines:
>> find_package(Qt3 REQUIRED) # find and setup Qt3 for this project
>> find_package(KDE3 REQUIRED) # for kde3_automoc
>> add_definitions(${QT_DEFINITIONS} ${KDE3_DEFINITIONS})
>> This has worked fine for years, but when I now try to do a 'configure' 
>> in ccmake, I get this error:
>>  CMake Error at /usr/share/cmake/Modules/FindKDE3.cmake:109 (STRING):
>>    string sub-command REGEX, mode MATCH needs at least 5 arguments 
>> total to command.
>>  Call Stack (most recent call first):
>>    CMakeLists.txt:10 (find_package)
>> That specific line in that file looks like this:
>>    STRING(REGEX MATCH "KDE: .\\." kde_version ${kde_config_version})
>> This is on Fedora 10, and there has been a system update last night. 
>> It is possible that something went wrong during that update, because 
>> the machine crashed when I tried to log in.
>> What could be the cause of that error, and how can it be fixed?
> What version of cmake is this?

cmake version 2.6-patch 2


Disclaimer: http://www.kuleuven.be/cwis/email_disclaimer.htm

More information about the CMake mailing list