[Cmake] CMake 1.6 beta

Ian Scott ian . m . scott at stud . man . ac . uk
Wed, 8 Jan 2003 15:49:28 -0000


Hi,

I have tested been testing CMake 1.6 on Linux, compiling both VXL, and our
internal code (which uses a lot of the qt wrapping commands) and it works -
great work! Thanks!

I have also been looking through the Modules directory - which benefitted
several months ago from the importing of functionality from VXL's
FindXXX.cmake files. I was wondering if the variable naming scheme that was
discussed at the time will become standard (CMake/Modules/readme.txt). Andy
changed FindX11.cmake which used to fit this standard. Instead of
X11_INCLUDE_DIR, we now have CMAKE_X_INCLUDE_DIRS? I think this is wrong -
consistent naming of such variables is really useful. Is there a reason for
X11 status being in the "CMAKE_" pseudo-namespace rather than in "X11_"?

I also found the following issues, which I have fixed in the repository.

Since the use of Modules/LinkQT.cmake was deprecated in CMake1.4, it is now
removed.
There was a bug (which I introduced some time ago) in FindPNG.cmake:17
  INCLUDE( INCLUDE(${CMAKE_ROOT}/Modules/FindZLIB.cmake )
VXL has 2 more Modules which I have contributed to CMake for MPEG2 (which is
apparently a completely different structure from MPEG) and for SDL.

Ian.

-----Original Message-----
From: Ken Martin [mailto:ken . martin at kitware . com]
Sent: Tuesday, January 07, 2003 3:53 PM
To: vtk-developers at public . kitware . com; cmake at public . kitware . com
Cc: 'Insight'
Subject: [Cmake] CMake 1.6 beta


CMake 1.6 beta has been released and can be downloaded from www.cmake.org or
form cvs as Release-1-6 If you encounter any problems please let us know.

Thanks
Ken

Ken Martin, PhD
Kitware Inc.
518 371 3971 x101
469 Clifton Corporate Pkwy
Clifton Park NY 12065