CMP0035ΒΆ

The variable_requires() command should not be called.

This command was introduced in November 2001 to perform some conditional logic. It has long been replaced by the if() command.

CMake >= 3.0 prefer that this command never be called. The OLD behavior for this policy is to allow the command to be called. The NEW behavior for this policy is to issue a FATAL_ERROR when the command is called.

This policy was introduced in CMake version 3.0. CMake version 3.17.20200406-g3acf6e4 warns when the policy is not set and uses OLD behavior. Use the cmake_policy() command to set it to OLD or NEW explicitly.

Note

The OLD behavior of a policy is deprecated by definition and may be removed in a future version of CMake.